install Bundle::CPAN on CentOS5.5 が失敗する件の解決方法

先ほどサーバーをリブートしたらtiarraが動かなくなったので、cpanにて、Scalar::Util を強制再インストールして、PPからXSにしたんですが。

そのときにCPANが install Bundle::CPAN してねーと言ってきたので指示通りインストールしようとしたら

Recursive dependency detected:
    ExtUtils::MakeMaker
 => M/MS/MSCHWERN/ExtUtils-MakeMaker-6.56.tar.gz
 => File::Spec
 => S/SM/SMUELLER/PathTools-3.33.tar.gz
 => File::Path
 => D/DL/DLAND/File-Path-2.08.tar.gz
 => File::Spec.
Cannot continue.

とか出る問題。
結局調べた結果、cpanを起動してから install Bundle::CPAN するのではなく、

perl -MCPAN -e 'install( q{Bundle::CPAN} )'

とperlに直接モジュールを読み込ませてアップデートするとよい模様。
原理はよくわかってない。

(via http://blog.laufeyjarson.com/2009/06/recursive-dependencies-in-cpan/ の コメント)

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です

このサイトはスパムを低減するために Akismet を使っています。コメントデータの処理方法の詳細はこちらをご覧ください